postheadericon    Тест по информатике и ИКТ


Задача 1

Найдите значение переменных      d,  k,  x
после выполнения фрагмента программы:


d : = 15;
k : = 22;
k : = 3 * k + 4 * d + 15;
d : = 3 * d + 15;
x : = 5 * k - 4 * d - 7;

d = 

k =  

x = 


Задача 2

Переведите число AD215 в систему счисления с основанием 2:




Задача 3

В какой системе счисления справедливо равенство:

       6 + 5 = 13

 в системе счисления с основанием   5
 в системе счисления с основанием   6
 в системе счисления с основанием   7
 в системе счисления с основанием   8
 в системе счисления с основанием   9


Задача 4

В представленном фрагменте программы значения одномерного
массива задаются с помощью оператора цикла:

Visual BasicПаскаль Алгоритмический
For i=1 to 5
a(2*i-1)=i
a(2*i)=i^2
Next
for i:=1 to 5 do
begin
 a[2*i-1]:=i;
 a[2*i]:=i*i;
end;
нц для n от 1 до 5
 a[2*i-1]:=i
 a[2*i]:=i*i
кц

Чему будет равно a[5] после выполнения этого фрагмента?


 3
 4
 5
 9
 25


Задача 5

Значения двумерного массива размера 7x7 задаются с помощью
вложенного оператора цикла в представленном фрагменте программы:

БейсикПаскаль Алгоритмический
FOR n=1 TO 7
FOR k=1 TO 7
B(n,k)=k-n
NEXT k
NEXT n
for n:=1 to 7 do
for k:=1 to 7 do
B[n,k]:=k-n;
нц для n от 1 до 7
нц для k от 1 до 7
B[n,k]:=k-n
кц
кц

Сколько элементов массива B будут иметь положительные значения?


 


Задача 6

Логический элемент по ГОСТ обозначается
следующим образом:

На выходе схемы будет 1 (истина), если


 X=1 или Y=1
 X=1 и Y=1
 X=1 и Y=0
 X=0 и Y=0
 X=0 и Y=1



Задача 7

Из перечисленных ниже устройств
устройствами ввода являютя:

(При необходимости множественного выбора
используйте вместе с мышью клавишу Ctrl)






Задача 8

В таблице приведены запросы к поисковому серверу.

Расположите обозначения запросов в порядке убывания
количества страниц, которые найдет поисковый сервер
по каждому запросу.

Для обозначения логической операции "ИЛИ" в запросе
используется символ |, а для логической операции "И" - &.


 
 
 
 
 
 
 


Задача 9

Укажите верное соответствие.

Файл с расширением

exe может быть создан в  

doc может быть создан в   

xls может быть создан в  

mp3 может быть создан в  

ppt может быть создан в